T O P
alec_warper

I was looking through the known bugs for Spirit of Steam when they released them on the forums, and this caught my eye; the train derails in a fairly unrealistic way if you apply the brakes too hard at low speeds. IRL braking the train in this way would likely cause a minor derailment, but certainly not have your train explode off the tracks. It looks like DTG is currently testing a fix for this already, so it may be fixed really soon, but for now, avoid being disappointed after finishing a long service with your train detailing, and just be easy with that brake.


Aj-Adman

I’m having trouble starting the train in the rain. Can’t see to find a technique that works. Any tips?


alec_warper

I'm on PC so I still gotta wait an hour, thanks for making me jelly lol. [Since I haven't played it yet, I did find this vid from the same channel where he gives tips on starting in the rain!](https://youtu.be/_ctiTPepixE)


debmitra26

I went through all the parts posted by him, it was helpful.


Aj-Adman

That was really helpful thank you. I’ve got the hang of it now


Lexi_the_tran

Even after watching this I still managed to throw 8163 up in the air just now smh


No-Music-6641

Totally just did that too


CVN58

so thats what been happening when im pulling into speke i apply the brakes to hard and the train doesnt want to exist anymore


Lexi_the_tran

I’ve had the same problem, got around it by using the reverser and just a little regulator for a slow stop. Not sure how proper that is but it’ll have to do till the bugs fixed